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ACT! Shared Folders Synchronization using WebDrive 
 
 

Introduction 

Remote User Synchronization with WebDrive 
Remote user synchronization of an ACT! database with WebDrive is an effective and time efficient 
solution to the remote ACT! user’s need to share contact information with peers. The underlying FTP file 
communication and transfer technology is wrapped in a familiar Windows interface afforded by the 
WebDrive FTP client. WebDrive permits ACT! to “see” the remote FTP server housing the central contact 
management database as a local shared folder. When a remote user initiates a synchronization session to 
another user or to the synchronization administrator a synchronization packet is created in the 
corresponding folder on the remote FTP server. The synchronization process can remain the same whether 
the user is off-site or attached to the internal network. In either case, WebDrive permits ACT! to treat the 
central database folder as a local folder and perform Windows I/O operations on it.  
 
 
Overview 

WebDrive Synchronization 
The ACT! synchronization process requires that each user have a copy of the database. Complete setup 
instructions on how to create a new, empty copy of an ACT! database can be found in the ACT Knowledge 
Base (http://itdomino.act.com/act.nsf/docid/20001129164749). This article will provide step by step 
instructions for creating databases for each of the remote users.  
 
In addition to having an empty copy of the database on each remote user’s computer, the server must be 
properly configured.  A detailed article in the ACT! Knowledge Base entitled “How To Share an ACT! 
Database on a Local Area Network (LAN)” (located at 
http://itdomino.act.com/act.nsf/docid/200228134824) documents the steps required to set up the server. It 
should be noted that the references to workstation setup in this article are for drive mapping via a local 
network operating connection and should not be used for remote database synchronization using 
WebDrive. Workstation drive mapping procedures are documented herein under the heading “WebDrive 
Folder Mapping”. 

WebDrive Folder Mapping 
WebDrive is configured so that each remote user maps a drive to the location on the network server where 
the shared ACT! folder resides. For ease of administration it is recommended that each remote user’s 
system be configured to map the same drive letter to the shared folder area on the FTP server. For purposes 
of this discussion, users will map drive T: to \\HQ-SERVER\ACT!\ACTSHARE\. On the WebDrive 
ADVANCED button (available from the “Open WebDrive” menu when right clicking the WebDrive icon 
in the Task bar) the root directory should be set to the fully qualified folder path:   
(“\\HQ-SERVER\ACT!\ACTSHARE\”). 
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Synchronization Folders  
Personal synchronization folders are required for each user who will synchronize with the central ACT! 
database. These folders will receive sync data from the central database and serve as a repository for data 
sent from the remote users to the central database. These folders are created under the root of the mapped 
WebDrive drive. For this example there will be three remote users that need to synchronize with the central 
database (Remote1, Remote2, and Remote3). The personal folder setup for these three users would be as 
follows: 
 \\HQ-SERVER\ACT!\ACTSHARE\Remote1 
 \\HQ-SERVER\ACT!\ACTSHARE\Remote2 
 \\HQ-SERVER\ACT!\ACTSHARE\Remote3 
 
An additional synchronization folder is needed for the ACT! database synchronization administrator. This 
user is referred to as the “Sync Admin” user. The folder for this user is: 
 \\HQ-SERVER\ACT!\ACTSHARE\Sync Admin. 

Remote User Synchronization Setup  
After the personal synchronization folders have been created, each remote user’s synchronization settings 
must be configured to communicate with the personal folders on the mapped WebDrive. The step by step 
process 
 

1. Start ACT! on the remote user’s workstation 
2. Log on as the remote user. 
3. Open the database being shared.  
4. Select File > Synchronize Setup. 
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5. In the Synchronization Setup Wizard dialog box click the radio button to select With other 
users 

6. Click the Next button.  
 

 
 

4. In the What Data? dialog box, clear the Send Updates selection at this point 
5. Check Receive Updates 
6. Select the types of contact data that you wish to synchronize 
7. Click the Next button 
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8. In the With Whom dialog box, choose or add Sync Admin to the Sync User list 
9. Select Next  

 

 
 

10. In the How dialog box, click the radio button to select Use shared folders. 
11. Browse to the Sync Admin’s synchronization folder mapped through WebDrive and double click 

the folder to populate the “Send these syncs to:” selection box. This folder is located at \\HQ-
SERVER\ACT!\ACTSHARE\Sync Admin. 

12. Click Next 
 

 
 

13. Select the All received syncs go: browse button and choose the synchronization folder 
corresponding to the user being configured. If Remote1 is being configured, the entry in this 
selection box would read \\HQ-SERVER\ACT!\ACTSHARE\Remote1. This setting can be 
selected from the Edit > Preferences > Synchronization dialog. 

14. Click Next 
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15. In the Receive What Data dialog box, check Private data and Field definitions to indicate the 
type of information to receive as required. 

 
16. Click Next 

 

 
 

17. In the Send What Data dialog box, click the radio button to select All contacts, all groups and 
Private data to indicate what data is to be sent. 

18. Click Next 
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19. At this point in the setup you do not want to schedule regular synchronizations of the data. That 
activity will be configured after the first synchronization has been completed and verified as 
successful. Select No 

20. Click Next  
 

 
 

21. Clear the Send Updates box for the first synchronization. The first sync will only receive data. 
22. Select Synchronize to begin the process. 
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23. After initial sync the user will select File > Synchronize 
24. Check the Send updates box. This will permit full synchronization.  

 

 
 

Server Synchronization Setup  
In addition to configuring the individual users’ workstations for synchronization, the ACT! server 
application must be configured to send and receive updates. The server sync is set up on the server using 
the Sync Admin account. The initial sync will be done manually and subsequent syncs can be done 
automatically through the Scheduler. For automatic synchronization to occur the central ACT! database 
must be opened and the Sync Admin user will need to be logged in.  

Building the database  
The overall process requires activities on both the server and the user’s workstation. The initial database 
resides on the server and a full synchronization is done for each user. A blank database is created (if one is 
not already created) on the users PC and synced with the server. On subsequent syncs only files and records 
updated from the last sync are transferred.  

Initial Server Synchronization Setup 
The server setup centers around the selection of the correct send and receive folders for the synchronization 
with each user. The “Send these syncs to:” folder is set to the users sync folder previously created on the 
mapped WebDrive drive.  
 
For this example, the folders are identified as follows: 

 \\HQ-SERVER\ACT!\ACTSHARE\RemoteX 
where “RemoteX” corresponds to the remote users’ account.  
 
The “All received syncs go:” folder is set to the Sync Admin user’s sync folder previously created on the 
mapped WebDrive drive.  
 
For this example, the Sync Admin sync folder is identified as follows:  

\\HQ-SERVER\ACT!\ACTSHARE\To Admin  
 

Note that this setting must be set this on the Edit | Preferences | Synchronization screen. 
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Future Server Synchronization Setup 
 
Future synchronizations can be either initiated on demand using the Synchronize command under the File 
menu or scheduled from the “Synchronization” tab under the “Preferences” selection from the Edit menu.  
 
For an on-demand synchronization you must select the Synchronize command under the File menu. That 
command brings up the following screen.  If your WebDrive is mapped to the shared folder server you 
select “Synchronize” at the bottom of the screen to begin the process.  

 
 
A series of “Working…”screens will display the progress of the communication.  
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Once the communication has completed you will be returned to the main ACT! screen. The 
synchronization packet has been delivered to the selected user’s shared folder area on the server. The next 
time the Remote2 or Remote3 users synchronize, the sync packets will be applied (in creation order) to 
their copy of the database.  
 
The other method of synchronization involves creating a sync schedule; much like you would do when 
setting up a scheduled event using Microsoft Windows Scheduled Tasks. After you have verified that your 
sync settings have been properly configured – via the setup process previously described you can create a 
scheduled sync to occur on a regular basis. 
 
To schedule database synchronization, use the “Synchronization” tab under the “Preferences” selection 
reachable from the main Edit menu. The tab displays the following screen. 
 

 
 
The “All received synchronizations go:” entry box will already have been filled in during previous sync 
setup activity. At this point you make the desirable selections, indicating whether to send or receive or do 
both; selecting the type of data to be sync’ed, etc. once all the settings have been selected, click the 
“Schedule” button to get to the following configuration screen.   
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This screen enables you to select the desirable days of the week and time of day for the sync to take place. 
It should be noted that in order for the sync to properly execute, the WebDrive mapped to the shared folder 
server must be connected at the time of the synchronization.  After setting the time and day, select OK to 
return to the main Preferences screen. Select OK again to return to the main ACT! contact window.  
 
Once these steps have been completed, ACT! will synchronize with the selected users via the shared folder 
server at the preset time. It should be noted that ACT! must be running on your PC and logged in under 
your user name for the synchronization to take place. A log of the sync activity is maintained and entries 
will be made on the Notes tab of your “My Record” database entry.  

Scheduled WebDrive Command Line Execution  
 
If you are not able to keep your mapped WebDrive active all of the time, you can create a small text file 
that will execute a command line connection to the appropriate shared folder using WebDrive. The 
connection file (e.g. WebDriveConnect.BAT) would contain the following command line: 
 

"c:\program files\webdrive\WebDrive.exe”   /S:"ACTSHARE"  
 
…where c:\program files\webdrive\WebDrive.exe is the full path to the WebDrive executable and 
“ACTSHARE” is the name that you assigned to the shared folder connection configured in the WebDrive 
configuration screen. This command causes WebDrive to execute and make a connection to the previously 
configured ACTSHARE site name.  
 
This .BAT file could then be added to Windows scheduled tasks to execute just before the time that you 
configured the ACT! synchronization to take place. This would insure that a WebDrive would be mapped 
to your shared folders area of the server.  
 
Another .BAT file with the following line could be created and scheduled to automatically disconnect the 
WebDrive drive mapping at the appropriate time:  
 
 "c:\program files\webdrive\WebDrive.exe”    T:/D 
 
…where c:\program files\webdrive\WebDrive.exe is the full path to the WebDrive executable and “T:” is 
the letter of the mapped WebDrive configured in the WebDrive configuration screen. This command causes 
WebDrive to disconnect from the drive mapped to T.  
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This combination of scheduled ACT! synchronization and scheduled WebDrive connects and disconnects 
fully automates your synchronization process.  
 
Conclusion 
The need to share up to the minute data between remote users and their peers continues to grow in the 
expanding global community. Remote user synchronization of an ACT! Database with WebDrive provides 
a user friendly Windows interface for the FTP file transfer technology that allows users to share time 
sensitive data. Synchronization of the ACT! Database with WebDrive provides remote and internal users 
with an efficient and secure communications tool. 
 
About South River Technologies 
South River Technologies, headquartered in Annapolis, Maryland, develops file management software that 
is used for file collaboration, website management and shared access. SRT’s unique client technology 
creates an instantly familiar interface by integrating seamlessly into the Windows Operating System. 
Founded in 1996, South River Technologies directly sells and markets Windows based utilities, and 
licenses its technologies to Software Publishers and Independent Software Vendors.  
 
For more information about South River Technologies’ products ,please contact 
sales@SouthRiverTech.com or visit http://www.SouthRiverTech.com. 
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